System Requirements
 
The NYU School of Professional Studies Website
Faculty
Degrees
Professional Certificates
Upcoming Events
Search Courses
Credit Course
Non-Credit Course

Browser Requirements

The NYU School of Professional Studies website is best viewed using the latest version of Microsoft Internet Explorer*, Mozilla Firefox, Apple Safari, or Google Chrome for the PC (running Windows 7) or the Mac.  At minimum, we support the following browser versions:

  • Internet Explorer (Windows 7)* 8.0+
  • Mozilla Firefox 8.0+
  • Apple Safari 5.2+
  • Google Chrome 16.0+

For the New Noncredit Programs website, we support the following browser versions:

Desktop:

  • Microsoft Edge (Windows 10)
  • Internet Explorer 11 (Windows)
  • Chrome 49 (Windows, Mac OS X)
  • Firefox 45 (Windows, Mac OS X)
  • Safari 9 (Mac OS X)

Devices:

  • iPhone/iPad: Mobile Safari (iOS 8)
  • Mobile/Tablet: Chrome 49 (Android 4.4)
  • Mobile/Tablet: Android Browser (Android 2.3)
  • Windows Phone: Internet Explorer 11 (Windows Phone 8.1)
  • Microsoft Surface: Internet Explorer 11 (Windows RT 8.1)

However, if you are using older versions of the browser, you may notice that the site may work but the results may be less than optimal.

Updating your web browser only takes a few minutes and it's free. To update or to learn more about the latest version of a browser, please click on one of the links below:

Report a Site Problem

If you notice a problem with the website, such as pages not displaying correctly or error messages, please let us know by email. Describe the problem in detail and provide the page URL, along with the operating system and browser version you are using, in your email message.
Email Us

* We do not recommend using Internet Explorer 10 on Windows 8 or using browsers for Windows XP to view our website, as IE10 does not run many custom-built web applications built for earlier browsers and Microsoft has ended its support of Windows XP as of April 8, 2014. We are sorry for any inconvenience this may cause.